This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Custom Layouts Not Applying to Pages

  • Creator
    Topic
  • #1283
    mrhinkle
    Member

    I am unable to get custom layouts to apply to my pages. The homepage layout should be Showcase Blogger but the other pages where i have built and applied custom layouts to the pages still default to Showcase Blogger Layout. Any ideas on how to make sure the custom layouts are applied correctly?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #1293
    Jason Bobich
    Keymaster

    Hello,

    Can you tell me more about the site you’ve setup specifically? Is it possible you have set this page as your “posts page” under Settings > Reading > Frontpage displays? If so, you need to undo this, and not select anything as your posts page.

    #1305
    mrhinkle
    Member

    Jason,

    The settings for Settings > Reading > Frontpage displays is the radio button “Latest Posts”.

    • This reply was modified 7 years, 9 months ago by mrhinkle.
    • This reply was modified 7 years, 9 months ago by mrhinkle.
    #1314
    Jason Bobich
    Keymaster

    It sounds like they’re just a simple misunderstanding of how custom layouts work. Can you link me to a specific page where you’re trying to apply a custom layout so I can see what you’ve setup?

    #1316
    mrhinkle
    Member

    The site is http://www.socializedsoftware.com
    The home page seems to render as desired using the Showcase Blogger layout.
    I then created a custom layout called About http://www.socializedsoftware.com/about
    The images at PIctureStack show the Builder page and the About page in WordPress
    http://picturestack.com/181/950/yUcEditPageSoq1V.png
    http://picturestack.com/181/950/GPeLayoutBuilYun.png
    Thanks for your help.

    #1320
    Jason Bobich
    Keymaster

    Ok, I don’t think issue has anything to do with custom layouts or the theme; it looks like something is misconfigured with your WordPress installation and your permalinks.

    If you look at your site, every page on your site is simply pulling the theme’s homepage file, as if it can’t find any of the pages on your site. I have a feeling there’s something screwed up with your Permalink settings. What happens if you go to Settings > Permalinks and put them back to “Default”? Do pages now show up properly?

    If so, it means you’ll need to troubleshoot your WP install and how you’ve set things up. Here’s a lot of helpful information on this topics: http://codex.wordpress.org/Using_Permalinks

    #1424
    mrhinkle
    Member

    Thanks, that was the problem. I set the permalinks to default and it works.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The forum ‘Akita Responsive WordPress Theme’ is closed to new topics and replies.