This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Conflict with Postman SMTP plugin

  • Creator
    Topic
  • #24275
    benz1
    Member

    Hi, I’m getting a conflict between Barely Corporate (4.1.8 & 4.1.9.1) and the Postman SMTP plugin. Everything was working fine and the front end has no problems but now when I tried to log into the Admin panel I was just getting a blank page. By removing all plugins and putting them back one by one I narrowed the problem down to Postman SMTP. When I try to activate it I get a blank screen. I changed to Twenty Fifteen and the plugin activates correctly but then when I tried to activate Barely Corporate again I get the blank screen. No errors and nothing in the error logs.

    Any suggestions? I really need Postman SMTP (unless you can suggest an alternative) as the host (Crazy Domains) will not send email from the contact forms to email addresses on the same domain without using a 3rd party SMTP server.

    Thanks in anticipation.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Author
    Replies
  • #24276
    Jason Bobich
    Keymaster

    Hi,

    Have you tried turning on WP_DEBUG to try and get an error to show we can work with?

    https://codex.wordpress.org/WP_DEBUG

    #24278
    benz1
    Member

    Thanks for your prompt response.

    With WP_DEBUG turned on getting the following warnings at the front end:

    Notice: wp_register_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/shalomco/public_html/wp-includes/functions.php on line 3622

    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/shalomco/public_html/wp-includes/functions.php on line 3622

    Notice: wp_register_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/shalomco/public_html/wp-includes/functions.php on line 3622

    Notice: wp_enqueue_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/shalomco/public_html/wp-includes/functions.php on line 3622

    And at the back end (with Postman SMTP active and blank screen):

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/shalomco/public_html/wp-includes/functions.php on line 3570

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 32 bytes) in /home/shalomco/public_html/wp-content/plugins/wordfence/lib/wordfenceClass.php on line 3055

    With Postman SMTP inactive the 2nd line re Wordfence disappears.

    Thanks.

    #24280
    Jason Bobich
    Keymaster

    So none of those notices on the frontend or backend are from our theme. I’d assume they’re from plugins you’re using, but all are non critical.

    That last fatal error is your answer though, and why you can’t access your admin. It’s not any kind of specific incompatibility; it’s just a matter of the accumulation of the theme and all your plugins are using up more memory than allowed.

    From your wp-config.php, where you turned on WP_DEBUG, you can also increase your allowed memory for WordPress:

    https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    #24281
    benz1
    Member

    Thanks, I had already tried this to no avail but just tried again with debug turned on with 96M & 128 M but it is still showing the 67108864 bytes exhausted error. I guess I’ll need to try to get the host to increase it but I’m a little confused as <?php phpinfo(); ?> is showing memory_limit as 128M. If 128M is already allocated should the WP_MEMORY_LIMIT not be able to utilize up to 128MB?

    I guess the fact that it worked with the Twenty Fifteen theme just means that Barely Corporate uses more memory?

    Thanks.

    #24282
    Jason Bobich
    Keymaster

    Yeah, the Barely Corporate theme has many more options and features than Twenty Fifteen, along with the fact that when you disable Barely Corporate, you’re also efftively disabling the other ThemeBlvd plugins like shortcodes and layout builder. So sure when you activate Twenty Fifteen you’re using less memory.

    Have you tried increasing past 128M?

    #24283
    Jason Bobich
    Keymaster

    Also make sure you’ve read through the various notes there on the codex page that I linked you to.

    #24284
    benz1
    Member

    Yup, tried up to 160M but makes no difference.

    #24285
    benz1
    Member

    Thanks, have disabled all the non-essential plugins and it is now below the threshold so at least Postman SMTP is activated again. Thanks for your support, I appreciate this is not directly a barely Corporate issue.

    #24286
    Jason Bobich
    Keymaster

    It may be worth upping it to something like 256M or higher, just for the sake of experimentation. It would be nice to know if your host is prohibiting you from using the WP constant somehow.

Viewing 9 replies - 1 through 9 (of 9 total)

The forum ‘Barely Corporate Responsive WordPress Theme’ is closed to new topics and replies.