This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Center text/button in Slogan area

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #9046
    Jason Bobich
    Keymaster

    Hello,

    From what I’m looking at, I can’t really see how these items are not vertically centered already, but maybe we’re just seeing different things from different browsers.

    But unfortunately the only options available for the Slogan element are what you see there in the Builder interface. Anything other modifications would be CSS changes you’d need to make to the theme. Note that vertically centering anything in CSS can be a tricky road to go down.

    ======

    For CSS changes, it’s a good idea to use a tool like firebug or Google Chrome’s built-in developer tools to locate them and then put the edits either in your child theme or in the “Custom CSS” option on your theme options page.

    Also, here’s a helpful tutorial on how to use Firebug – http://vimeo.com/20917974. The only thing I’d suggest not doing is actually making edits to the theme’s CSS files, as it shows at the end of that video. However, the video serves as a good introduction to Firebug and how it can be used to find what CSS is effecting certain areas of your site without ever digging around in any files.

    #9056

    Hi Jason,
    Thanks for the quick reply.
    Do you see the white strip right above the “Get Started Today!” box (I see it in your screenshot above). That strip should be gray like the rest of the slogan box. It looks fine (centered) if I change the Content color to Dark, but I’d like the Light color (gray).
    Scott

    #9061
    Jason Bobich
    Keymaster

    Do you see the white strip right above the “Get Started Today!” box

    Scott, can I ask, are you viewing your site on a HiDPI screen when you see this on your live site? Like a retina MacBook Pro?

    And to actually tackle the issue, try pasting this in the “Custom CSS” option of your Theme Options page:

    #main .element-slogan,
    #main .element-tweet {
    	background-color: #ffffff;
    	background-image: -webkit-gradient(linear, left top, left bottom, from(#ffffff), to(#f0f0f0));
    	background-image: -webkit-linear-gradient(top, #ffffff, #f0f0f0);
    	background-image: -moz-linear-gradient(top, #ffffff, #f0f0f0);
    	background-image: -o-linear-gradient(top, #ffffff, #f0f0f0);
    	background-image: -ms-linear-gradient(top, #ffffff, #f0f0f0);
    	background-image: linear-gradient(top, #ffffff, #f0f0f0);
    	filter: progid:DXImageTransform.Microsoft.gradient(GradientType=0,StartColorStr='#ffffff', EndColorStr='#f0f0f0');
    }
    #9062

    Thanks Jason. That did the trick.

    By the way, I have a Dell HD 23″ monitor (1920 x 1080), as well as a 2009 MacBook.

    Great job designing these themes. The videos are very helpful too. I’m new to WordPress so I’m still figuring things out but your theme builder is very handy.

    Thanks!

    Scott

Viewing 4 replies - 1 through 4 (of 4 total)
  • The forum ‘Akita Responsive WordPress Theme’ is closed to new topics and replies.