This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Tagged: 

Can Not Edit Content on Page

  • Creator
    Topic
  • #19270
    Derek Dalton
    Participant

    I am trying to edit my content on a page that has a Custom Layout. Before the update, I could edit the content on the page and now I can not.

Viewing 9 replies - 16 through 24 (of 24 total)
  • Author
    Replies
  • #19487
    jbisonaroll
    Participant

    I’m using Gravity Forms v1.8.19. The editor is available whenever I disable that plugin. To test it I disabled all plugins except the plugins that come with the theme and Gravity Forms. When I do that the editor disappears. When I disable GF the editor returns and continues to work fine whenever I add back the other plugins. I can show you screenshots if you want/need me to.

    I haven’t contacted GF b/c we’re not having this problem on any of the other 645 sites where we use GF.

    Keep in mind that this is isolated to one specific page on the website (which I sent to you privately). The strange thing is there’s not even a form on this page. Really odd problem…

    #19493
    Jason Bobich
    Keymaster

    So, you’re saying that the problem only occurs when you’re editing this one page, “religion-a” ? Activate the Gravity Forms plugin so the issue is there, and then get out of editing that page. I’ll login and take a look.

    #20740
    jbisonaroll
    Participant

    Hi Jason,

    We’re having the exact same problem all over again. Do you mind working your magic again?

    Thanks,
    JB

    #20742
    Jason Bobich
    Keymaster

    What happenedast time? I don’t remember? But there are no conflicts between the theme and gravity forms when editing a page.

    #20743
    jbisonaroll
    Participant

    If you read this chain of messages you’ll know what happened and what the problem is/was. Here it is in a nutshell. When the Gravity Forms plugin is turned on the visual editor does not work on certain pages (which oddly enough do not contain forms).

    I took all the steps you previously suggested – turning off the plugins individually to find the problem, clearing the cache, etc – none of them helped. When I switch to another theme everything works fine. It’s something to do with your ThemeBlvd Plugins and/or theme that’s causing the issue.

    You logged into the site last time and found the problem. If memory serves me correctly you fixed the issue in a later update to the theme or plugins.

    Your help is much appreciated.

    Thanks,
    JB

    #20747
    Jason Bobich
    Keymaster

    Yup, I read the chain, but the last message I see is from me saying this:

    So, you’re saying that the problem only occurs when you’re editing this one page, “religion-a” ? Activate the Gravity Forms plugin so the issue is there, and then get out of editing that page. I’ll login and take a look.

    I’m looking at the issue now on your site … but did we previously continue talking about about this somewhere else?

    #20750
    Jason Bobich
    Keymaster

    Can you turn WP_DEBUG to true in your site’s wp-config.php?

    The issue has something to do with Revisions for the page. What’s happening is that when the Edit Page loads, there is a PHP Fatal error and the page stops loading when WordPress tries to print the Revisions box. The fact that your visual editor is broken is just a side effect of the page breaking before it’s all loaded.

    Anyway, if you turn on WP_DEBUG, we can get an error to print on the screen when that break happens, that could possibly give us a clue to what the issue is.

    #20766
    Jason Bobich
    Keymaster

    My best guess, at this point: I have a feeling this is a memory issue. I don’t think you’re having any conflict with a particular plugin like our’s or Gravity Forms.

    Instead I think this is just the accumulation of all plugins using up too much memory when the Edit Page screen loads (our Layout Builder and Gravity Forms are both plugins that add quite a bit of functionality, and would add load to the page). So, this combined with a page that has a high amount of revisions that need to be retrieved by WordPress just pushes that limit enough to break.

    If this is the issue, the solution is fairly simple. You’d just increase your PHP memory limit from your site’s wp-config.php.

    http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    … That’s maybe one thing you could try if you can’t figure this out.

    #20793
    jbisonaroll
    Participant

    Hi Guys,

    Thank you for looking into this and for the suggestions. I did as you said and increased the amount of memory allocated to PHP. Additionally I installed WP Optimize and and used it to clear out all the old revisions and clean up the rest of the database. Everything seems to be working fine now.

    Thanks again!

    Enjoy the day,
    JB

Viewing 9 replies - 16 through 24 (of 24 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.