This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Layout Builder and Demo Content

  • Creator
    Topic
  • #6719
    er777
    Participant

    Hi,

    Fresh new install of Jump Start
    1) I see no Builder button in admin
    2) Demo content import has many errors – but i followed directions exactly..

    ie: ( there were 146 errors – here are the first 3 )

    Failed to import “Example Background”: Invalid post type optionsframework
    Failed to import “Unique Id”: Invalid post type optionsframework
    Failed to import “Test Slide”: Invalid post type optionsframework

    How can i resolve this?

    Thanks

Viewing 15 replies - 1 through 15 (of 24 total)
  • Author
    Replies
  • #6720
    er777
    Participant

    This link I found on a Page Edit :
    http://dev.erdigitaldesign.com/wp-admin/admin.php?page=builder_blvd

    throws this error:
    You do not have sufficient permissions to access this page.

    #6721
    er777
    Participant

    I realized I had the Theme Blvd Admin Hide Plug In activated ( but it was recommended to be installed…! that seems like a mistake , don’t you think? ..based on the confusion it caused me )

    #6722
    er777
    Participant

    So i still want to import all the sample data ( with no errors ) so that I can REALLY learn about and use this theme and framework. What am I missing?

    #6723
    Jason Bobich
    Keymaster

    Hello,

    1) I see no Builder button in admin

    Have you installed the Layout Builder plugin? — http://wordpress.org/extend/plugins/theme-blvd-layout-builder/

    2) Demo content import has many errors – but i followed directions exactly..

    The demo content has a lot of content that you’ll need the Sliders plugin, Layout Builder plugin, and Widget Areas plugin installed to work right.

    As far as the errors with optionsframework, I’ll look into getting an updated sample content file, but realistically those errors don’t really effect anything I don’t think.

    #6724
    Jason Bobich
    Keymaster

    I realized I had the Theme Blvd Admin Hide Plug In activated ( but it was recommended to be installed…! that seems like a mistake , don’t you think?

    I assume you mean this? Maybe you misread somewhere when activating Jump Start, or maybe had this already previously on your WP install? Jump Start would not have prompted you to install this.

    #6725
    er777
    Participant

    Thanks for the quick response!

    I do have all these plugins installed.

    [IMG]http://i47.tinypic.com/1j68if.jpg[/IMG]

    As I said there were 143 non loaded files..
    http://utility.erdigitaldesign.com/jumpstart-import-errors.rtf

    #6726
    Jason Bobich
    Keymaster

    I’m testing the sample data file now, and I’ll see what’s going on with that.

    #6727
    Jason Bobich
    Keymaster

    So, I’m testing it now and not getting any errors. Are you sure you’re importing the sample data that came with Jump Start? And not one of the other Theme Blvd themes or some kind of older sample content file?

    #6731
    er777
    Participant

    Absolutely using the sample items from the Jump Start download…

    #6732
    Jason Bobich
    Keymaster

    Either way, all of the things in the errors from the text file you uploaded are irrelevant to the content you’re importing. Even with the errors, you should still have all of the content imported if you now go to your Pages, Posts, Builder, Slider pages, etc. Is this not the case?

    #6734
    er777
    Participant

    OK – looking a little better..

    http://dev.erdigitaldesign.com/features/layout-builder/sample-layouts/business-homepage-1/

    But is this the way the site should look? Missing frames around the pics and the video on main slider in Home is huge and stretching the height..

    Tx!

    #6735
    er777
    Participant

    It looks like things have settled down.. propagation? Who knows.. looks a lot better. Looking forward to using this framework.

    And thank you for such quick responses. I realize i may have just gotten lucky today. But, no matter, MUCH appreciated!

    Eddie

    #6736
    Jason Bobich
    Keymaster

    But is this the way the site should look? Missing frames around the pics and the video on main slider in Home is huge and stretching the height..

    Yup, you got it. — http://www.themeblvd.com/demo/jumpstart/features/layout-builder/sample-layouts/business-homepage-1/

    If you want frames around the pics there’s a class in the framework (and Bootstrap) you can use called “thumbnail” —

    <img src="image.jpg" class="thumbnail" />

    The slider is huge because one of the slides has a full video in it. It’s just showing you all the different options you could do in the slides of a slider. From your Child theme, you could hard code fixed heights if you wanted, or more realistically, you’d be using more consistant slides when building your slider.

    #6738
    er777
    Participant

    Quick question – in order to hide Commenting ( Blog type functionality – remove the “Leave a reply”boxes, etc ) I can of course go in and cut wp code up – either css or php, but there must be a better way to do this globally..??? or by page ? or by any other category?

    #6739
    Jason Bobich
    Keymaster

    There is an option under Post Options when editing an individual post that the framework gives you that you can use to hide the comments.

    If you’re just looking to hide the comment form for posts throughout your entire site, the framework has a filter you can use from your Child theme’s functions.php —

    function my_remove_comments( $setup ) {
        $setup['comments']['posts'] = false;
        return $setup;
    }
    add_filter( 'themeblvd_global_config', 'my_remove_comments' );

    Reference:
    http://dev.themeblvd.com/tutorial/managing-framework-features/

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.