This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Blog page not showing more than 2 posts

  • Creator
    Topic
  • #4101
    cowboymike
    Participant

    Hi Jason,
    I dont know if this has changed on my site or if it is suppose to be this way but I noticed my blog pages are pagenating after just displaying 2 posts. I cant find a setting for this. I do have in the wordpress settings Reading>Blog pages show at most 24 posts.

    Can you please have a look at my blog pages here: http://www.hibiscusbythebay.com/blog/

    Happy trails, Mike

Viewing 9 replies - 1 through 9 (of 9 total)
  • Author
    Replies
  • #4103
    Jason Bobich
    Keymaster

    This will be controlled by Settings > Reading > Blog pages show at most. The only way I can think that it would be possible for this not to be the case is that you have added a custom field over on the page where you have that blog page template applied limiting the number of posts per page? I can’t think of any other reason why the general WordPress setting wouldn’t be taking effect with how you have it setup.

    #4112
    cowboymike
    Participant

    Hi Jason,

    I havent added any custom fields. I tried deactivatiing all the plugins and that had no affect.

    I noticed the recent Posts and the mini post grid of recent posts seem to be out of wack as well. On the main page the sections of recent posts and post grid are showing more posts than what is being shown on the blog pages.

    Do you think this could be related to the recent 3.5.1 WP upgade?

    I noticed my local sandbox/dev version of the web site is doing the same thing and it was upgraded to wp 3.5.1 as well.

    I’d be happy to give you admin access if you would care to look around. I would be willing to pay you for your time.
    Thanks, Mike

    #4116
    cowboymike
    Participant

    Jason,
    I looked at the default Alyeska and it has “Settings > Reading > Blog pages show at most.” is set to 10. But on the blog page on the default Alyeska I think more than 20 posts show before it is pageinated. So its not clear to me what controls the number of posts on the blog page before it is then pageinated.

    I have been trying to compare settings to see what might be different in the live site vs the default Alyeska but have not had any luck yet.
    Thanks, Mike

    #4124
    cowboymike
    Participant

    Hi Jason,
    I have tried to trouble shoot this by doing the following:
    1. deactivating all plugins. This resulted in no changes. Same behavior.

    2 switched to the default theme(s) to rule out any theme-specific problems. It seems like when I did this then the main page of the default themes showed all the posts in the post list.

    3. I reset the plugins folder by FTP or PhpMyAdmin in case an apparently inactive plugin was causing problems. I used the ftp method cited here: http://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

    Since the default themes seemd to show all the posts it may imply something to do with Alyeska. I may just have a setting wrong.

    I dont know what else to do or try. My offer to give you admin access still stands. πŸ˜‰

    Thanks for your time and consideration.
    Mike

    #4134
    Jason Bobich
    Keymaster

    Send the WordPress admin login information and I will check it out. Go to My Account > Submit Private Info here on the support forum.

    #4142
    cowboymike
    Participant

    Thanks Jason,
    I sent the login info as per your instructions but it wasnt clear from the Submit Private Info screen that it actually got sent.
    I could send it your your email address which I still have if you dont get it from the forum.
    Thanks, Mike

    #4145
    Jason Bobich
    Keymaster

    I honestly have no idea why that’s happening with your setup. However, I set your site up in a slightly modified way so that you don’t experience the issue on your blog page.

    I created a static page called “Homepage” and applied your custom homepage layout to it. Under Settings > Reading, (1) I set that as your static frontpage, and (2) I set your blog page as your “posts page.” — The only downside to this is that you can’t use any paginated elements in your homepage layout, which can be a little cumbersome for your website visitors anyway in the homepage layout.

    #4150
    cowboymike
    Participant

    Hi Jason,
    Thank you so much man. I sure appreciate it. I sure couldnt figure out what was going on and why it was happening.

    I can work with the change you have made just fine. Thank you so much. πŸ™‚

    Do you think the database is corrupted?
    Do you think I should have someone look at the database?

    Can you explain to me what you mean when you wrote: “can’t use any paginated elements in your homepage layout”

    Do you mean for example, in my custom home page layout I have a Post Grid (paginated) to display the condos listed for sale.

    Do you mean that that wont work?

    Thank you for your time and efforts Jason. If you ever need a testimonial for your marketing I will be happy to write you something. And if you have a paypal account I will be happy to pay you.

    Thanks man, Mike

    #4163
    Jason Bobich
    Keymaster

    Do you mean for example, in my custom home page layout I have a Post Grid (paginated) to display the condos listed for sale.

    Yeah, so you need to use the standard “Post Grid” instead is all. If it has pagination, the pagination links will come up as 404’s because WordPress can’t handle pagination on a static frontpage for some reason.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.