This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Blog page error

  • Creator
    Topic
  • #1649
    marchroc
    Participant

    I am hosting a WordPress network at hmsites.org, my blog is located here: http://www.hmsites.org/student-blogs/ . Right now it is hidden because I get this error on any page I set up as the main network blog:
    Warning: Invalid argument supplied for foreach() in /home/hmnjsd/hmsites.org/wp-content/themes/alyeska/framework/frontend/functions/general.php on line 801

    What I am trying to eventually do is set up my sitewide tags to aggregate all of my students’ blog posts and be able to subscribe to it through rss. The issue right now is this error code I am running into. If you could help, I would appreciate it greatly. Thanks for the wonderful theme!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #1651
    Jason Bobich
    Keymaster

    Hello,

    It looks like you may have started a custom layout and either never finished it, or deleted it after you assigned it to your homepage. What’s happening is that it’s trying to pull from a custom layout that’s either not there or doesn’t have any elements.

    Keep in mind that you may be confusing some settings here. Currently it looks like you’ve gone to Settings > Reading > frontpage displays, and selected a “posts page” — Is this correct?

    When you do this, you’re effectively telling WordPress that this is your “homepage” and so whatever you assigned as a homepage layout under Appearance > Theme Options > Content > Homepage is what it’s going to try and pull. If you’re simply trying to display a simple blog there, you don’t need any “posts page” and you don’t need the layout builder.

    Go to the page that you’re creating as your “Blog” and apply the “Post List” page template. Then go back to Settings > Reading > Frontpage displays and make sure there is NO posts page selected.

    Does that solve your issue?

    #2007
    marchroc
    Participant

    Unfortunately it did not solve my issue. I am getting a too many redirects error.

    #2011
    marchroc
    Participant

    You know, it’s ok. I am able to generate a feed and that is all I need to monitor my students. I do not need anyone to view the page. I have another plugin working that does that. Thanks!

    #7558
    msiep
    Participant

    I had this issue too when trying to add a blog page that is NOT my home page, having previously used only static pages on my site. Fortunately I found this topic, and it led me to find the solution.

    The problem was that in Appearance / Theme Options / Content I had at some point in the past specified a Custom Layout for the home page, but I had later decided I did not need to use a custom layout, so I didn’t have any. Even though the posts page I’m adding is not used as my home page (in Settings / Reading) this still caused this error.

    #7562
    Jason Bobich
    Keymaster

    Yeah, I’ve had quite a few people run into this issue. I understand why it’s confusing. For the next update, I’ve already put in a “user-catch” that basically doesn’t apply the homepage layout if that “homepage” is set as a “posts page” — Assuming that if this is the case, the user has made a mistake.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.