This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Blog only loading first page of posts

Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #2602
    Jason Bobich
    Keymaster

    Is it possibly a permalinks issue? What happens if you turn off permalinks at Settings > Permalinks?

    #2604
    2x4labs
    Participant

    How do you turn OFF permalinks?

    I tried other permalink settings and they didn’t work. The current permalink structure was specifically requested by my client, so I’d like to keep it.

    #2608
    Jason Bobich
    Keymaster

    As a troubleshooting method to see if that is the issue with your site, you should turn them off temporarily. To turn them off, go to Settings > Permalinks, set them to “default” and save the Settings page.

    #2609
    2x4labs
    Participant

    That breaks the blog link entirely.

    #2610
    Jason Bobich
    Keymaster

    lol, yes because permalinks are turned off… Please try and work with me here. I’m only trying to help you.

    Ok, let’s try this again. Here’s how we will troubleshoot. We first need to figure out if this is a permalinks issue on your site or not.

    Step 1: Go to Settings > Permalinks, and set them to default.

    Step 2: Visit the frontend of your website and click the “Our Blog” link on your main menu bar.

    Step 3: From your blog page, try and click to next page or posts.

    Are you still not able to get to the next page of posts? Or do they work now?

    #2611
    2x4labs
    Participant

    The blog page doesn’t even load though. It shoots back a 404. So I can’t click to next pages or posts… that’s what I meant by “it breaks the blog link entirely”.

    #2613
    Jason Bobich
    Keymaster

    What I’m saying is that if you have permalinks turned off, your blog link should be completely different. It should be something like: http://www.phillymarketinglabs.com/?page_id=50 … Unless you have something overriding default WordPress functionality, and I am noticing some odd redirecting going on here with your blog page.

    Do you have some sort of 3rd-party WordPress plugin that points this:

    http://www.phillymarketinglabs.com/philadelphia-marketing-blog/

    To this:

    http://www.phillymarketinglabs.com/blog/

    #2616
    2x4labs
    Participant

    I see the problem. Someone set up a custom link to http://www.phillymarketinglabs.com/philadelphia-marketing-blog/ in the main menu instead of just setting up the blog page.

    The problem was not your theme.

    Thanks for your support, your response time was great.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.