This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Auto resize embed youtube

  • Creator
    Topic
  • #451
    prozachtx
    Participant

    I have a lot of posts with YouTube videos embedded in them. Is there any way to have the video automatically re size when viewing the post on a smaller device like an iPhone?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Author
    Replies
  • #453
    Jason Bobich
    Keymaster

    Hello,

    How are you currently embedding your videos?

    The theme automatically wraps videos with HTML to make them responsive. So, if your videos are embedded in the standard WordPress way (i.e. like this), you shouldn’t have to do anything. Does that make sense?

    #454
    prozachtx
    Participant

    I simply posted the long link into the post:

    http://www.youtube.com/watch?v=jAPPpoFfqTE

    If you look at the post on an iphone you will see that it does not resize to the smaller format:

    http://www.tvcops.com/tased-and-confused-norwood/

    #455
    prozachtx
    Participant

    I’ll try and post a screen shot here:

    • This reply was modified 8 years ago by prozachtx.
    #459
    Jason Bobich
    Keymaster

    On your site, aside from the fact that the theme’s wrappers aren’t being applied, the video is also not embedded in the default way. It has some extra stuff around it. I remember seeing this same issue with someone else’s site once, but for the life of me, can’t figure out what it ended up being.

    Do you have any plugins installed on your site that have anything to do with YouTube or embeds or videos? There has to be something else that is conflicting.

    #460
    prozachtx
    Participant

    Yes sorry I was just experimenting with a couple resizing plugins. It’s back to normal now. I found one that did the trick but the cell padding around the video was huge

    #462
    prozachtx
    Participant

    Problem solved with the plugin “fitvids for wordpress”. Any way to get this to work without the plugin? Seems like the video adjusts to size changes but only to a certain point. Then it stops resizing smaller. The result is a half cropped video when viewed on a small screen device like the Iphone.

    #463
    Jason Bobich
    Keymaster

    No, see the problem is that you’re using a plugin at all. When you enable these plugins, you’re overriding what the theme does. The first time, you had another plugin enabled that was overriding the theme’s filter on videos. And now, although it’s giving you the result you want, you still have a plugin overriding what the theme does. Just disable all your video plugins, and the theme will make the fluid by default.

    #506
    ejb5oh
    Participant

    Jetpacks feature like this caused me issues.  I did not know that Alyeska did that too.  I disabled jetpacks shortcodes and now it works like a champ!!  Your themes rock!

    #508
    prozachtx
    Participant

    Thanks ejb5oh! That solved the problem!

    #509
    Jason Bobich
    Keymaster

    Aw, so jetpack is doing it. Good to know.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.