This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Add media with caption means no lightbox?

  • Creator
    Topic
  • #14732
    edsteenhoek
    Participant

    Hi,

    I have the same issue as posted here: http://support.themeblvd.com/forums/topic/add-media-to-page-adds-lightbox-shortcode-when-caption-not-set/

    Yet, due to having bought another theme, I can’t read the answer which means you have to answer it again for me in the forum of my theme…

    Do I need to remove the caption on order to get the lightbox?
    If so, how is the caption made visible on lightboxed images?

    And a little sidestep: how about grouping the lightboxed images in a set?
    The [lightbox_gallery] doesn’t seem to do the trick…

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #14733
    edsteenhoek
    Participant

    The lightbox gallery does after the page has been published. Probably a hickup in the WordPress preview.
    Caption on the portfolio list page still is missing (it does show in the lightboxed images).

    #14738
    Jason Bobich
    Keymaster

    Hello,

    This is called the “Auto Lightbox” feature that goes with our shortcodes plugin. I would say, as of now, inserting an image with a caption is definitely a quirk in the system that doesn’t work very well.

    Here’s a video about it from your documentation:

    https://vimeo.com/65843469

    And here’s how to disable it, as shown in the end of the video:

    In your WP admin, go to Settings > Writing > Theme Blvd Shortcodes and there will be an option to disable this feature.

    Do I need to remove the caption on order to get the lightbox?

    If you’re working with a captioned image, you can’t use our [lightbox] shortcode on that image, because WordPress is using a completely different shortcode to display this, which is called the [caption] shortcode.

    And a little sidestep: how about grouping the lightboxed images in a set?
    The [lightbox_gallery] doesn’t seem to do the trick…

    I just setup an example of instance of the [lightbox_gallery] for you to see. Everything is working as it should on my end. Is it possible you’re misunderstanding what the [lightbox_gallery] does? What are you specifically trying to do that is different from the above example?

    http://demoblvd.com/themes/akita/test/

    #14739
    Jason Bobich
    Keymaster

    Caption on the portfolio list page still is missing (it does show in the lightboxed images).

    Can you link me to an example of what you’re calling a “portfolio list page”? Are you talking about a post grid like this? — If so, this would just be a featured image followed by the excerpt. There wouldn’t be any where here a caption would be showing.

    #14744
    edsteenhoek
    Participant

    Thanks for the fast reply.
    The url: http://orlando.edsteenhoek.nl/item/animal-kingdom/
    It is a restricted site, so I created an user and pw.
    Both: TBSupport.

    This is the setup I created:
    – Foto’s is a page of the post grid template.
    – It displays the portfolio called fotos.
    – That portfolio has a few portfolio items.
    – Animal Kingdom is one of the items and has several photos that I added with add media.
    – Because I removed the caption, add media now inserts the lightbox option.

    On the Foto’s page, each item has a caption which serves as a title of the photo collection in an item.
    On the Animal Kingdom page, none of the photo’s has a caption, but the lightbox does.
    Here too I want to add a title to the image.

    This is the text of the page:

    [lightbox_gallery]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8674.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8674-300x200.jpg" width="240" align="left" title="Macaw papegaai" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8687.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8687-300x200.jpg" width="240" align="left" title="Springbok (vrouwtje)" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8688.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8688-300x200.jpg" width="240" align="left" title="Springbok (mannetje)" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8689.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8689-300x200.jpg" width="240" align="left" title="Bengaalse tijger" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8753.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8753-300x168.jpg" width="240" align="left" title="Witte neushoorn" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8709.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8709-300x200.jpg" width="240" align="left" title="Kerkuil in vlucht tijdens de show" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8712.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8712-221x300.jpg" width="221" align="left" title="Kerkuil" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8679.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8679-199x300.jpg" width="199" align="left" title="Vleermuis" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8740.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8740-300x300.jpg" width="240" align="left" title="Uil" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8744.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8744-300x280.jpg" width="240" align="left" title="Uil" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8729.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8729-300x300.jpg" width="240" align="left" title="Amerikaanse zeearend" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8769.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8769-300x300.jpg" width="240" align="left" title="Giraffe" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8774.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8774-300x200.jpg" width="240" align="left" title="Giraffe" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8812.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8812-300x200.jpg" width="240" align="left" title="Zebra's" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8829.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8829-300x200.jpg" width="240" align="left" title="Animal Kingdom" frame="true" icon="image"]
    [/lightbox_gallery]
    #14745
    Jason Bobich
    Keymaster

    How about just using a standard WordPress [gallery]? Are you familiar with how to do this? When you do this, you can setup image captions. This is all outputted by WordPress (not the theme), and then to this, we add on automatic lightbox support when you link the gallery to the media items.

    When you create a gallery to insert into your page, you input the captions as normal. Also, make sure in the Media Settings (see right side of screenshot), “Link to” is set to “Media File”:

    This will result in WordPress displaying the captions below the thumbnails on the page, and then you’ll notice the theme transforms the images to link to lightbox popups.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The forum ‘Akita Responsive WordPress Theme’ is closed to new topics and replies.