This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Add Media to page – adds lightbox shortcode when Caption not set

  • Creator
    Topic
  • #12266
    mharpen
    Participant

    I’m using Alyeska 3.0.2, and when I add a photo to a page (via Add media button), and set the “caption” to blank, and the Link to the photo, the following long shortcode is inserted into the wysywig visual editor instead of the photo. When i specify a caption, the photo is shown in the visual editor as normal. In both cases, i am specifying a link to the photo. If I remove the link, it also inserts the photo in the editor as normal.

    To clarify, When adding a photo to the visual page editor – without a Caption, and with a Link to the photo specified, it inserts the following shortcode into the visual editor instead of a normal img tag. But if I specify a Caption, it inserts the img tag with a caption shortcode surrounding it.

    [lightbox link="http://mysite.org.previewdns.com/wp/wp-content/uploads/2012/10/myphoto.jpg" thumb="http://mysite.org.previewdns.com/wp/wp-content/uploads/2012/10/myphoto-300x225.jpg" width="300" align="left" title="myphoto" frame="true" icon="image"]

    I’ve disabled any editor type plugins. Is this something the theme is doing? Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #12268
    Jason Bobich
    Keymaster

    This is called the “Auto Lightbox” feature that goes with our shortcodes plugin.

    Here’s a video about it from your documentation:

    https://vimeo.com/65843469

    And here’s how to disable it, as shown in the end of the video:

    In your WP admin, go to Settings > Writing > Theme Blvd Shortcodes and there will be an option to disable this feature.

    #12269
    mharpen
    Participant

    Thanks! Why is it not consistent whether or not there is a Caption specified? It does not create the Lightbox shortcode if a caption is specified.

    #12270
    Jason Bobich
    Keymaster

    Because in order for WordPress to output a caption, it does a whole other thing with its own [caption] shortcode. When you insert your captioned image, switch over to the “Text” tab in your editor, and you’ll see what I mean.

    #12273
    mharpen
    Participant

    Yes, I saw that in the text tab ([caption] a tag img tag [/caption]). It was making me crazy trying to figure out why the caption was causing a difference. If you can do anything to keep it consistent that would be appreciated. Such as replace the whole [caption] a tag img tag [/caption] with the Lightbox shortcode. Thanks again!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.