This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

a lightbox for images

  • Creator
    Topic
  • #1442
    greenteafilm
    Member

    Hi there.
    I set up a featured image on post to be shown in a light box. It worked fine except it is showing that there are two images (duplication) and when I click “arrow” it shows the same image even though there is only one image.
    How can I fix this?

Viewing 15 replies - 1 through 15 (of 19 total)
  • Author
    Replies
  • #1451
    Jason Bobich
    Keymaster

    Hello,

    Can you please provide a link to the issue?

    #1460
    greenteafilm
    Member

    http://www.greenteafilmandtv.com/filming-location/#!prettyPhoto

    when you click the image, it shows in a light box but as you can see it says 1/2 when it has got only one image..

    #1461
    greenteafilm
    Member

    It gets worse, as I added one more image and now it shows 2/4?? while I have got only 2 images..
    I will send you my admin details and hopefully you can figure out what I have done wrong…

    #1471
    Jason Bobich
    Keymaster

    The issue is pretty straight forward. PrettyPhoto is just grouping all lightbox images on the page together. So, you’ve got the two in the main area and the two in the sidebar. Remove the mini post list widget from the sidebar and you’ll notice you won’t be seeing the issue.

    Another way you could solve this issue with customization is to change the gallery ID that gets used for featured image in the post grid to be something specific:

    If you install the Child theme, you could copy content-grid.php to your Child theme and then inside find this:

    <?php themeblvd_the_post_thumbnail( $location, $size ); ?>

    And change to this:

    <?php themeblvd_the_post_thumbnail( $location, $size, true, true, 'gallery_posts' ); ?>

    … The point of all this being to add a unique gallery ID at the end which I wrote as “gallery_posts” — but it could be anything other than “gallery”

    #1496
    greenteafilm
    Member

    Thank you. it sounds I had better use the child theme then.
    I have just installed the child theme, but it shows “Indication about problems” in WP admin panel, what do I need to do?
    Just “skip” this?

    #1497
    Jason Bobich
    Keymaster

    I have just installed the child theme, but it shows “Indication about problems” in WP admin panel

    I honestly don’t know what this means. Can you explain this a little? Maybe a screenshot or something? — http://picturestack.com

    #1498
    greenteafilm
    Member

    sorry. please disregard what I said.
    Can you please go through what I need to do in order to set up the child theme properly and set up the things you explained about the gallery posts thing.

    #1499
    greenteafilm
    Member

    I have installed the plug in “WP-editor” and changed name of the theme to “Akita Child Theme” and added Jason’s name as an author, from here, where and how I copy content-grid.php to the Child theme and find this <?php themeblvd_the_post_thumbnail( $location, $size ); ?> in order to change to <?php themeblvd_the_post_thumbnail( $location, $size, true, true, ‘gallery_posts’ ); ?>

    Thank you

    #1500
    Jason Bobich
    Keymaster

    There are many ways you can access files on your server. Your web host should have given you FTP Access, to which you can use an FTP client. Or, maybe if your host has some sort of user interface like cPanel, you have some other way to also manage your files.

    On your server (where ever you have WordPress installed), you can find the files of your Parent theme here:

    /wp-content/themes/akita/

    And you can find the files of the Child theme here:

    /wp-content/themes/akita-child/

    #1502
    greenteafilm
    Member

    Hi. sorry to bother you.
    Although I can see all the files but I don’t see the code <?php themeblvd_the_post_thumbnail( $location, $size ); ?> anywhere.

    I have seen only “functions.php” “screenshot.png””style.css” and a folder “assets”that has “css” folder and “images” folder.

    #1518
    Jason Bobich
    Keymaster

    This is because you’re looking in the child theme’s directory only. Get out of your WordPress admin panel, and use an FTP program (or some other way to manage the files on your server).

    Within here: /wp-content/themes/akita/

    Find the file called content-grid.php and copy it to here: /wp-content/themes/akita-child/

    #1528
    greenteafilm
    Member

    I checked the files on my server not in WordPress admin panel but still I couldn’t find the file “content-grid.php”

    #1532
    greenteafilm
    Member

    Sorry Jason.
    I finally managed to find it and changed it.
    I hope it works.

    #3789
    sebclarke
    Member

    Hi, I am trying to solve the same issue, however I want the lightbox to show just the single image that has been clicked rather than a gallery of images related to the post… is this possible? I would also like to display the meta information about the image (caption, description etc) in this lightbox – is this possible also?

    Thanks,

    Seb

    #3802
    Jason Bobich
    Keymaster

    Hello,

    What issue exactly are you trying to solve? Can you explain your problem in more detail.

    I would also like to display the meta information about the image (caption, description etc) in this lightbox

    Apologies, but this isn’t possible.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The forum ‘Akita Responsive WordPress Theme’ is closed to new topics and replies.