This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Reply To: Superfish settings for nav not sticking

#2300
Jason Bobich
Keymaster

Hello,

I’m not totally sure I’m following what you’re trying to do. In this theme there is no shadow that Superfish is putting on the drop down menus that I’m aware of? That dropShadows parameter you’re fiddling with shouldn’t do anything because I don’t include the CSS needed for it to work; I never have in any of my themes.

In this theme, all superfish’s javascript is doing is the following:

  1. Animating the dropdown menus in on hover.
  2. Outputting the arrows next to top-level menu items with dropdown menus.
  3. Delaying the dropdown menu before it fades out when the user hovers off.

But anyway, there’s no cache or anything on the javsacript files unless you have some sort of caching plugin on your WordPress site. If you’re trying to change a parameter of superfish, you wouldn’t want to actually edit the superfish plugin file itself. You’d edit the themeblvd.js file from your Child theme where the superfish function is called, and pass different parameters to the function.

http://dev.themeblvd.com/tutorial/overriding-a-framework-javascript-file/#example-2

$("ul.sf-menu").superfish({ 
     foo: 'bar',
     foo2: 'bar2'
});

Now, from your CSS snippet you’re putting in here, it would suggest you’re talking about just the text shadow on the menu items in dropdowns? If so, this wouldn’t have anything to do with superfish. But your CSS snippet should work. I just tried it on my end and it did remove the CSS text shadow effect from the menu items.

Maybe I could better help if you showed me a screenshot fo what you’re referring to and maybe a live link to your site?