This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Reply To: Post content showing twice

#2134
Jason Bobich
Keymaster

Everything is behaving as expected, but I think you may have yourself mixed up on which custom layouts you’re editing.

You have currently have two layouts. One is called “forside1” and it is set as your homepage under Appearance > Content > Homepage.

In this custom layout you have two elements:

  1. Content Element
  2. Post List Element

In the Content Element, you’ve selected to show the content from the current page as its content source. Because this custom layout is not assigned to a static page, there is no page to pull content from, and thus the result is that it’s pulling content from the first post in the queue.

So, how to get rid of the six lines of text above your post list in your custom layout? — Go to Layout Builder. Edit the “forside1” layout. Delete the “Content” element.

And an even better solution? — If all you’re wanting to show on your homepage is a post list and nothing else, you don’t even need a custom layout at all. Simply go to Appearance > Theme Options > Content > Homepage > Homepage Content and select “Posts”. The theme’s default state is already a standard WordPress Blog setup.