This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Reply To: Mailpress and news scroller plugin

#519
Jason Bobich
Keymaster

It seems your plugin is actually including jQuery manually right in there widget instead of enqueuing jQuery in a hooked function to wp_enqueue_scripts properly and executing their jQuery in a non-conflicting way.

Here’s a screenshot of what I’m talking about. The plugin is actually manually including entire javascript files and jQuery inline with the widget’s markup.

http://picturestack.com/231/314/ZUeScreenShotlhC.png

Honestly, with any plugin that is omitting such basic practices, you should be careful with on your site. You’re going to run into conflicts with any other plugin that uses jQuery and proceeds it. In other words, the problem doesn’t have anything to do with the news scroller widget other than the fact that it’s placing jQuery code after the other plugin has essentially broken things moving down the page. You might even be able to get away with flip-flopping the two plugins and having the news scroller come before the other one breaks the jQuery going on with the page.