This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Reply To: Blog Layout

#407
Jason Bobich
Keymaster

Hello,

Did you set a “posts page” under Settings > Reading? And is that what you’re calling your “blog” page? — If so, that’s the issue.

When you do this, WordPress using this as your “homepage” as it sees it (remember that WordPress is meant to be a blog homepage website by default). And because of this, what you’ve done to the page you’ve designated as your posts page becomes irrelevant, because WordPress is no longer using the theme’s designated files for displaying a page.

So, basically all you need to do is go to your Settings > Reading and if you’ve set the page to be your “posts page” change that option to be blank to allow for your true page template to show (i.e. Post List or Post Grid) you’ve chosen on that page you want to be your blog.